Back to overview
Degraded
Problem loading Taktile Frontend
May 18, 2026 at 10:08am UTC
Affected services
User interface
Resolved
May 18, 2026 at 11:52am UTC
Fix validated
Affected services
Updated
May 18, 2026 at 10:35am UTC
Fix is still inbound, new estimate for resolution is within 30 minutes.
Affected services
Updated
May 18, 2026 at 10:24am UTC
Issue is expected to be resolved within 15 minutes.
Affected services
Created
May 18, 2026 at 10:08am UTC
We've noticed an issue with accessing Taktile's Frontend on app.taktile.com. We have found the issue and working on a fix.
This does not impact production usage of Taktile.
Affected services