Back to overview
Degraded
Customers Experiencing Login Issues
Aug 28 at 09:42am CEST
Affected services
User interface
Resolved
Aug 28 at 10:05am CEST
The login issue has been resolved
Affected services
Created
Aug 28 at 09:42am CEST
Some customers are experiencing login issues. Our team is investigating the cause and working on restoring access as soon as possible
Affected services